Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 137] New - test fail on solaris /bin/sh != /bin/bash

pysvn
Discussion topic

Back to topic list

[Issue 137] New - test fail on solaris /bin/sh != /bin/bash

Author barryscott
Full name Barry Scott
Date 2009-09-10 12:26:05 PDT
Message http://pysvn.tigris.​org/issues/show_bug.​cgi?id=137
                 Issue #|137
                 Summary|test fail on solaris /bin/sh != /bin/bash
               Component|pysvn
                 Version|current
                Platform|Macintosh
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|extension
             Assigned to|barryscott
             Reported by|barryscott






------- Additional comments from barryscott at tigris dot org Thu Sep 10 12:26:04 -0700 2009 -------
Problem reported by Skip Mantano

When running the pysvn tests on Solaris they fail (at least test-01.sh
does) because
the script is actually a bash script not a Bourne shell script. On
Solaris /bin/sh is
really and truly an ancient dialect of Bourne. I think your test
scripts should explicitly
reference /bin/bash in the shebang line.

« Previous message in topic | 1 of 2 | Next message in topic »

Messages

Show all messages in topic

[Issue 137] New - test fail on solaris /bin/sh != /bin/bash barryscott Barry Scott 2009-09-10 12:26:05 PDT
     [Issue 137] test fail on solaris /bin/sh != /bin/bash barryscott Barry Scott 2015-11-06 05:16:41 PST
Messages per page: